Download old iOS apps on not supported devices

kuba - Wednesday, 1 May 2019
Download old iOS apps on not supported devices

When you are using an older Apple device you will be surprised visiting the AppStore that you can't install you favorited apps because they are not supported by your iOS version. Discover how to download old iOS apps on not supported devices.

Life is much easier when you are running a jailbroken device using tools like unc0ver or Chimera. You can install a free jailbreak tweak LowerInstall allowing you to download incompatible apps on older versions of iOS. If the app you trying to install doesn't use unique technologies for higher iOS version than you should be fine to run the app on your device. This is how to install LowerInstall tweak.

Install Apps in lower iOS version using LowerInstall tweak

Step 1. Open the Cydia app on your device.

Step 2. Tap Sources → Edit → Add the official http://julioverne.github.io repo.

Step 3. Switch to Search Tab and enter LowerInstall.

Step 4. Tap the Install button.

Step 5. Configure the tweak from Settings → LowerInstall.

Step 6. After installing reboot your device.

The LowerInstall jailbreak tweak works with AppStore and sideloaded apps (installd).

When you are running an iPhone, iPad, or iPod that is not jailbroken you have still an option to install older apps on your iOS device. The solution requires you to have a new version of Apple device. How to bypass the message "This application requires iOS 12 or later. You must update to iOS 12 in order to download and use this application." in order to install Netflix app on a not supported iOS.

Old Apple devices

Step 1. Install the Netflix app from AppStore on the new device.

Step 2. Open AppStore on iOS 9.3.5 or older.

Step 3. Navigate to Purchased.

Step 4. Select the Netflix app to install.

Step 5. Confirm the dialog box to download the last compatible version.

This way you can easily download and install any other app on iOS 5.1.1 or older. The downside is that you need to purchase or install the app in the past to have an option to download the latest supported version by your device. Of course, it doesn't work on every app so you need to test it by yourself.

Related Articles